"The spectrogram requires an enabled OpenGL context"

All about the tools and techniques involved in capturing sound, in the studio or on location.

Moderator: Moderators

Post Reply

"The spectrogram requires an enabled OpenGL context"

Post by Gone To Lunch »

This message has started appearing in my sonible smart:comp.

Dr Google reveals it is something to do with my graphics card, but I don't understand what, or what I need to do about it?
Gone To Lunch
Frequent Poster
Posts: 888 Joined: Fri Jun 11, 2004 12:00 am Location: London
http://www.gonetolunchmusic.com/

Re: "The spectrogram requires an enabled OpenGL context"

Post by BJG145 »

This fix worked for someone on the Internet.

Q) After a fresh install on my mac, when i open up a project with smart:comp already in it i get the message: The spectrogram requires an OpenGL context. Can you explain what this is, the plugin doesn't seem to be working right. Thank you.

A) It seems as if OpenGL (GPU accelerated graphics rendering) is disabled for smart:comp.

You can try to go to the settings page (little cog-wheel) and enable the button "Use OpenGL" there.

If that's not possible, you're most likely using an OpenGL version below v3.2. In this case the plug-in will disable OpenGL automatically to avoid graphics problems.

That said - even if OpenGL is disabled, all the audio processing continues to work without any limitations. The only downside is that you can't see the history visualization for the spectral compression. I hope this helps?
User avatar
BJG145
Jedi Poster
Posts: 5422 Joined: Sat Aug 06, 2005 12:00 am

Re: "The spectrogram requires an enabled OpenGL context"

Post by Gone To Lunch »

BJG145 wrote: Wed Aug 04, 2021 9:58 am This fix worked for someone on the Internet.

Big thanks BJG145!

It worked for me too!
Gone To Lunch
Frequent Poster
Posts: 888 Joined: Fri Jun 11, 2004 12:00 am Location: London
http://www.gonetolunchmusic.com/
Post Reply