Arturia Keystep 37 issues.

For fans of synths, pianos or keyboard instruments of any sort.

Moderator: Moderators

Arturia Keystep 37 issues.

Post by Arpangel »

I’m having trouble getting my Keystep to interface with my modular, it works fine via Midi, and USB, but I’m not getting anything via the CV outputs, Gate, Pitch.
If I connect it to an envelope generator or an oscillator in my modular, it seems to output a continuous voltage, not a gate, instead of coming on only when I press a key, the lights on my envelope generators stay on all the time.
Also, the arpeggiator doesn’t seem to be sending anything.
All of my other synths with CV outputs work fine with my modular, I’m a bit puzzled I may be missing a setting on the Keystep.
User avatar
Arpangel
Jedi Poster
Posts: 9194 Joined: Sat Jul 12, 2003 12:00 am
"Don’t let the noise of other peoples opinions drown your inner voice"

Re: Arturia Keystep 37 issues.

Post by Ben Asaro »

Unfortunately, I don't own a K37, but I do own two regular KS, A KSP, a BeatStep, and a BSP. I don't imagine they operate terribly different from each other.

Though it should work right out of the box, have you connected it to a computer running MIDI Controller and checked the setup? Is it running on the latest firmware? Have you checked to see if other KS37 owners had the same issue and was it resolved with a firmware update?

Do you have any modules that have visual feedback, like an LED light indicating that it's receiving gate? When you connect the Gate output, what does that indicate? (Same with the CV)

Do you accidentally have the Hold function engaged?

Have you tried using the MIDI out? Does that work?
Ben Asaro
Frequent Poster
Posts: 1833 Joined: Thu Feb 26, 2009 12:00 am Location: NYC

Re: Arturia Keystep 37 issues.

Post by Eddy Deegan »

The outputs are somewhat configurable with the Arturia MIDI Control Center software but assuming it's not faulty (I'd be a bit surprised if it was) it sounds possible that you might have it patched incorrectly.

I own one but it's in The Netherlands and I've not had access to it for nearly 2 years! Checking the manual I see:

Keystep manual (page 13) wrote:
1.7.3. Pitch/Gate/Mod outputs

These are normally used to send electrical signals to an external device such as Arturia's popular analog synthesizers (MiniBrute/SE, MicroBrute/SE, MatrixBrute) or to a modular analog synthesizer.

The Pitch output is often referred to as Control Voltage or CV. The Gate output is sometimes known as a Trigger. The Mod output is a second type of Control Voltage output that can berouted to any number of destinations on the target device.

The MIDI Control Center allows you to configure the type of electrical signals sent by each output. See section 7.3 [p.56] for information about the signal types that are supported.


Keystep manual (page 56) wrote:
7.3. MOD/GATE/PITCH specifications

Some analog synthesizers have unusual implementations that are not fully compatible with the KeyStep 37 MOD/GATE/PITCH signals. Please refer to their specifications before making a purchase so you can be sure the two devices will work together well.

We've designed KeyStep 37 to be as flexible as possible, though: the MIDI Control Center allows you to configure the response of the MOD/GATE PITCH jacks in a number of ways.

• PITCH has two options, each with its own keyboard reference settings:
◦ 1 Volt/octave (0-10V)
◦ 0 volt MIDI note range: C-2 to G8
◦ Hertz per volt (max ~12V)
◦ 1 volt MIDI note range: C-2 to G8 (1V reference default: C0)

• The GATE output has three options:
◦ S-trigger
◦ V-trigger: 5 volts
◦ V-trigger: 12 volts

• The MOD output has eight options ranging from 0-12 volts. By setting the Max voltage for this output, you can fine-tune the effect of the MOD output or accomodate devices that do not respond well to higher voltage levels.

See Chapter 9 [p.64] for a description of the related MIDI Control Center parameters.

User avatar
Eddy Deegan
Moderator
Posts: 6605 Joined: Wed Sep 01, 2004 12:00 am Location: Brighton & Hove, UK
Some of my works | The SOS Forum Album projects
 

Re: Arturia Keystep 37 issues.

Post by Arpangel »

Ben Asaro wrote: Wed Sep 22, 2021 12:56 pm Unfortunately, I don't own a K37, but I do own two regular KS, A KSP, a BeatStep, and a BSP. I don't imagine they operate terribly different from each other.

Though it should work right out of the box, have you connected it to a computer running MIDI Controller and checked the setup? Is it running on the latest firmware? Have you checked to see if other KS37 owners had the same issue and was it resolved with a firmware update?

Do you have any modules that have visual feedback, like an LED light indicating that it's receiving gate? When you connect the Gate output, what does that indicate? (Same with the CV)

Do you accidentally have the Hold function engaged?

Have you tried using the MIDI out? Does that work?

Thanks everyone, I have EG's that have lights to indicate they are receiving Gate/Triggers, they stay on all the time when the KS is connected, the Hold button is "not" engaged.
When I swap out the KS and connect my Moog Grandmother all works perfectly, I connect the gate out, and keyboard CV out, it’s fine, everything that works on the Moog connects to my modular, even the arpeggiator and sequencer.
The KS works fine with my computer, and my iPad over Midi, but there’s this continuous voltage over CV, and it makes EG's stick on, and produces a low rumble with oscillators.
I could work around this with a Midi Module, but what’s the point, seeing as the KS has CV!
User avatar
Arpangel
Jedi Poster
Posts: 9194 Joined: Sat Jul 12, 2003 12:00 am
"Don’t let the noise of other peoples opinions drown your inner voice"

Re: Arturia Keystep 37 issues.

Post by BigRedX »

Are you sending the correct gate type to the modular?

The part of the manual posted above show that there are three gate options S-trigger and two levels of voltage trigger.

IIRC Moog equipment uses s-trig rather than v-trig, which would explain why the Grandmother works as expected and why the modular has the trig lights continuously on. Have a look in the EG module's manual and see what sort of Gate it is expecting and then use the control program to change it to the correct one.
User avatar
BigRedX
Frequent Poster
Posts: 1124 Joined: Fri Sep 03, 2004 12:00 am
RockinRollin' VampireMan

Re: Arturia Keystep 37 issues.

Post by Hugh Robjohns »

As explained, the Arturia's outputs are configurable. It would be wise to learn how to configure them appropriately before dismissing it as an inadequate product!
User avatar
Hugh Robjohns
Moderator
Posts: 32368 Joined: Fri Jul 25, 2003 12:00 am Location: Worcestershire, UK
Technical Editor, Sound On Sound...
(But generally posting my own personal views and not necessarily those of SOS, the company or the magazine!)
In my world, things get less strange when I read the manual... 

Re: Arturia Keystep 37 issues.

Post by Arpangel »

Hugh Robjohns wrote: Thu Sep 23, 2021 9:48 am As explained, the Arturia's outputs are configurable. It would be wise to learn how to configure them appropriately before dismissing it as an inadequate product!

I’m not dismissing it, I’m puzzled as to why it’s not working, as I’ve looked at the default settings in the app, and they should be fine, I’ve sent a mail to support, hopefully they can sort it out.
User avatar
Arpangel
Jedi Poster
Posts: 9194 Joined: Sat Jul 12, 2003 12:00 am
"Don’t let the noise of other peoples opinions drown your inner voice"

Re: Arturia Keystep 37 issues.

Post by BigRedX »

Arpangel wrote: Thu Sep 23, 2021 10:59 am
Hugh Robjohns wrote: Thu Sep 23, 2021 9:48 am As explained, the Arturia's outputs are configurable. It would be wise to learn how to configure them appropriately before dismissing it as an inadequate product!

I’m not dismissing it, I’m puzzled as to why it’s not working, as I’ve looked at the default settings in the app, and they should be fine, I’ve sent a mail to support, hopefully they can sort it out.

In that case can you confirm what type of gate the Moog and Modular are expecting, and what type of gate the Keystep is currently outputting? My gut feeling is that the two receiving devices need different types of gate, which is the reason why one works and the other doesn't.
User avatar
BigRedX
Frequent Poster
Posts: 1124 Joined: Fri Sep 03, 2004 12:00 am
RockinRollin' VampireMan

Re: Arturia Keystep 37 issues.

Post by Ben Asaro »

Any joy, Arpangel?
Ben Asaro
Frequent Poster
Posts: 1833 Joined: Thu Feb 26, 2009 12:00 am Location: NYC

Re: Arturia Keystep 37 issues.

Post by Arpangel »

Ben Asaro wrote: Fri Sep 24, 2021 4:29 am Any joy, Arpangel?

Yes, it looks like the voltage standard on the Keystep could be "out of range' for some of my modules, it is adjustable, but obviously, not all modules are the same. My Moogs are 1 volt per octave, they seem to work fine on most things, but I’m finding generally that I have to transpose right down, and lower the range of oscillators, to get a usable range.
The reason why I’m not hearing anything is simply because the sound is way too high, I have to go into Control for the Keystep and play around.
Triggers and gates are sorted, you have to press buttons in the right order on Keystep, otherwise things just won’t work, it’s not instinctive.
I’m making progress, slowly.
User avatar
Arpangel
Jedi Poster
Posts: 9194 Joined: Sat Jul 12, 2003 12:00 am
"Don’t let the noise of other peoples opinions drown your inner voice"

Re: Arturia Keystep 37 issues.

Post by Ben Asaro »

If you’re talking about pitch, yes; the 0V pitch is different for every manufacturer, so you have to find a happy medium between the Arturia’s 0V pitch and where the oscillator is set.

Comes with the territory, the joy of modular lol. :headbang:

Glad you got it sorted!
Ben Asaro
Frequent Poster
Posts: 1833 Joined: Thu Feb 26, 2009 12:00 am Location: NYC

Re: Arturia Keystep 37 issues.

Post by Arpangel »

Ben Asaro wrote: Sat Sep 25, 2021 1:25 pm If you’re talking about pitch, yes; the 0V pitch is different for every manufacturer, so you have to find a happy medium between the Arturia’s 0V pitch and where the oscillator is set.

Comes with the territory, the joy of modular lol. :headbang:

Glad you got it sorted!

No Ben, I don’t like it, and it doesn’t like me, I don’t like the feel of it, or the way it works, I’ll be using my Moog as the controller for my Euro, when I need to, it just gets on with it, no software or any of that rubbish.
User avatar
Arpangel
Jedi Poster
Posts: 9194 Joined: Sat Jul 12, 2003 12:00 am
"Don’t let the noise of other peoples opinions drown your inner voice"
Post Reply