Downloads: I have done er, something!

For anything relating to music-making on Windows computers, with lots of FAQs. Moderated by Martin Walker.

Moderator: Moderators

Post Reply

Downloads: I have done er, something!

Post by ef37a »

For a very long time I had a shortcut on the desktop of this W10 laptop labelled simply "Downloads" and anything I found online that I wanted to grab I simply clicked on a download icon and it got sent to the folder which applied to the shortcut on, I had assumed, on the C SSD.

Because that SSD is rather small, a few weeks ago I moved the bulk of the downloads to an external USB drive. Now, when I try to open that shortcut I get a red blob and "The E drive this shortcut links to is no longer available...."

If I open 'This Computer' in the list on the left is "Downloads" but clicking on it still says "E drive not available".

I am assuming my USB drive is 'E' and there is something on it I need to put back but I don't want to re-stuff the C drive again!

So, what has this old fool done and can it be fixed?

Dave.
ef37a
Jedi Poster
Posts: 14409 Joined: Mon May 29, 2006 12:00 am Location: northampton uk

Re: Downloads: I have done er, something!

Post by Arpangel »

Dave, can’t you just start again? downloads is only a folder, just create one anywhere on your C Drive, and make a shortcut to it, for saving new downloads, the E drive , or USB drive doesn’t need a shortcut, does it?

:think:
User avatar
Arpangel
Jedi Poster
Posts: 11585 Joined: Sat Jul 12, 2003 12:00 am
That’s another thing

Re: Downloads: I have done er, something!

Post by Moroccomoose »

I'm not home just now, so can't verify my own advice... but... you can set the windows provided download folder location to anywhere. In file explorer, I think you can right click and go to properties and give any location of your choosing.
At the same time, you may wish to check in your browser settings where it s default download location is. (Not necessarily the same as the Windows default)
I have definitely changed my default download location to an alternative (not 'C') precisely to prevent a small SSD from cluttering. Will check when I get home.
Moroccomoose
Regular
Posts: 406 Joined: Tue Apr 12, 2011 12:00 am Location: Leicester

Re: Downloads: I have done er, something!

Post by ef37a »

Moroccomoose wrote: Sun Jun 26, 2022 9:05 am I'm not home just now, so can't verify my own advice... but... you can set the windows provided download folder location to anywhere. In file explorer, I think you can right click and go to properties and give any location of your choosing.
At the same time, you may wish to check in your browser settings where it s default download location is. (Not necessarily the same as the Windows default)
I have definitely changed my default download location to an alternative (not 'C') precisely to prevent a small SSD from cluttering. Will check when I get home.

Yes, that is something similar to what I had. I would click a download icon top of Firefox and the data would automatically go to the Downloads folder and I could access it from the desktop shortcut.

Tony: I have just created a Downloads folder in my C drive then put a shortcut to it on desktop. Next went to the Presonus site and clicked download for the user book. Had to find the shortcut on the desktop, i.e. not auto, and then when I opened it. "Folder empty".

I CAN download stuff but it defaults to the desktop which is cluttered anyway and gets ever more so!

My fault, I have borked something somewhere!

Dave.
ef37a
Jedi Poster
Posts: 14409 Joined: Mon May 29, 2006 12:00 am Location: northampton uk

Re: Downloads: I have done er, something!

Post by ef37a »

Fixed it!
Found that Firefox and many other browsers default to C/users/Downloads
Found that and set to "restore defaults. Next clicked dld on the SoS .pdf and it put it automatically into that folder and the desktop shortcut works again!

Thanks each, gave me ideas and a push to do something about it.

Dave.
ef37a
Jedi Poster
Posts: 14409 Joined: Mon May 29, 2006 12:00 am Location: northampton uk
Post Reply