Zoom LiveTrak L-20 Audio Interface Mode w/ Mac - SOLVED

All about the tools and techniques involved in capturing sound, in the studio or on location.

Moderator: Moderators

Post Reply

Zoom LiveTrak L-20 Audio Interface Mode w/ Mac - SOLVED

Post by Berus »

Hi all,

First, thanks to all who tried to assist me over the past few days with this issue. It's finally solved.

So, for anyone with a Mac who's struggling with the L-20 in Audio Interface mode, and having the L-20 show up in Sound input/output settings on your Mac, but getting NO SOUND... here's what worked for me:

USB mode set to CLASS COMPLIANT. This is referenced two places in the manual as being the correct setting for Macs, but the note under the Troubleshooting section contradicts this and tells you to turn the Class Compliant switch off - it doesn't clarify whether this is for both PC and Mac, or just for PC. If you have a Mac, you DO want Class Compliant ON.

USB 1-2/3-4 buttons turned on and lit.

NO PLUGS in those channel inputs! (This is what got me - if you have plugs in those, it will override the Mac's USB input.)

Audio in/out on Mac's Sound settings set to LiveTrak L-20 (not "Virtual L-20")

No messages/warnings in Privacy/Security tab notifying you about a blocked permission for Zoom drivers.

Latest Zoom drivers installed.

USB plug going directly into Mac (not a USB Hub), using a USB A to USB C adaptor (because there are no USB A ports on newer Macs, because... Apple.)

Latest firmware update (Note: in my case, my firmware was V. 1.23, while the latest version at Zoom's website was only V. 1.14 - attempting to "update" back down to this version gave me an error, so I had to stay with V. 1.23. If your firmware version is higher than the version available for download at the Zoom site, then you're OK - don't try to update to an older (lower) version number.

Hope this helps someone!
New here
Posts: 7 Joined: Sun Sep 25, 2022 9:48 pm

Re: Zoom LiveTrak L-20 Audio Interface Mode w/ Mac - SOLVED

Post by Wonks »

Congratulations on finding the solution!

These things really should be made crystal clear in the manuals.
User avatar
Jedi Poster
Posts: 13925 Joined: Thu May 29, 2003 12:00 am Location: Reading, UK
Reliably fallible.

Re: Zoom LiveTrak L-20 Audio Interface Mode w/ Mac - SOLVED

Post by flute700loop »

Hey thank you. I hope this works for me, just ordered a usb - c adapter and a usb - c midi cable.

Quick question. How did you figure out that USB hub wouldn’t work and you had to go direct to the Mac USB - port? I can’t find anything on this except for your post! Thank you !!
Posts: 1 Joined: Fri Dec 02, 2022 5:40 am

Re: Zoom LiveTrak L-20 Audio Interface Mode w/ Mac - SOLVED

Post by Berus »

Hi and sorry to be so slow getting back to you.

So, how did I find out the hub wouldn't work? Honestly, trial and error. A LOT of trial and error, during which I was not feeling patient, but forced myself to stick with it. My USB C/Thunderbolt hub is a Plugable (brand). Fairly expensive. This is the one that was supposed to work when others wouldn't. But, the Zoom wasn't having it. I assumed that, because my Apollo Twin X was cool with the Plugable hub, the Zoom probably would be too. Wrong assumption.

What I wish is that Apple would ease up on the whole "beauty of the clean industrial design" ethic just enough to PUT ENOUGH BLOODY CONNECTIONS on its devices. I have a MacBook Pro with 4 USB-C/Thunderbolt ports, and It's just not enough, given that one is going to the power plug. The whole plug/port issue is the ONLY place where I find myself really, really envying PC users.

Basically, this experience taught me the following: When something in my music production signal chain isn't working correctly - try taking it out of a hub and plugging it directly into the Mac. Do that before you spend 1-10 hours pulling your hair out with menus/settings/firmware, etc.

Hope this helps!
New here
Posts: 7 Joined: Sun Sep 25, 2022 9:48 pm

Re: Zoom LiveTrak L-20 Audio Interface Mode w/ Mac - SOLVED

Post by MarkOne »

I’m pretty sure there’s something about the M series architecture and the USB subsystem that’s just more fussy about what it will talk to. I’ve noticed a few cases like yours reported here and there.

When I swapped from my 2012 MBP to an M1 the icon control surface was unrecognised about 50% of the time, I literally had to power cycle it and suddenly it was there.

I suspect, because USB C is more than a simple serial bus and there is a handshake process going on, some low level firmware process is not managing this properly.

But the effected use cases are few and far between, so probably not very high up Apples bug fix list.
Frequent Poster (Level2)
Posts: 2119 Joined: Thu Feb 15, 2007 12:00 am Location: Bristol, England, Earth, Perseus Gap, Milky Way
My Music on Apple Music
My Music on Spotify
Post Reply